Customers are currently unable to complete open enrollment for medical, dental, and vision plans

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 20:44 EDT

Monitoring

We've implemented a fix and are monitoring for any lingering issues.
Posted Apr 03, 2025 - 18:16 EDT

Investigating

We are investigating an issue where customers are unable to proceed with open enrollment for medical, dental, and vision plans
Posted Apr 03, 2025 - 18:07 EDT
This incident affected: Justworks (Justworks Platform).