We are experiencing issues with page time outs and accessing reports
Incident Report for Justworks
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 17:56 EDT
Investigating
We're currently monitoring an issue that is causing sporadic page timeouts and issues that prevent customers from downloading reports.
Posted Sep 19, 2023 - 16:34 EDT
This incident affected: Justworks (Justworks Platform).