We are experiencing an issue with our platform

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 10:40 EDT

Investigating

We are currently investigating an issue with access to our platform. Our team is working to identify the issue and we will share an update on a resolution time soon.
Posted Aug 31, 2026 - 09:56 EDT
This incident affected: Justworks (Justworks.com Website, Justworks Platform, Justworks Mobile App), Justworks Time Tracking (Justworks Time Tracking Website, Justworks Time Tracking Platform, Justworks Time Tracking Mobile App), and Justworks Payroll (Justworks Payroll Platform).