We are experiencing an issue with our phone support services

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 19:18 EDT

Monitoring

A fix has been implemented and we are seeing improvements, but we will continue to monitor the situation.
Posted Jul 09, 2025 - 18:32 EDT

Identified

Our provider has identified the issue and is working to implement a fix.
Posted Jul 09, 2025 - 18:21 EDT

Investigating

We are currently investigating an issue with our phone provider and customers are unable to reach us by phone. We encourage customers to contact us via email (support@justworks.com) or via the Chatbot on our site for any immediate assistance.
Posted Jul 09, 2025 - 18:17 EDT
This incident affected: 24/7 Support.