We are experiencing intermittent issues on our platform.
Incident Report for Justworks
Resolved
This incident has been resolved.
Posted Dec 01, 2023 - 11:26 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2023 - 11:22 EST
Update
This incident has been resolved.
Posted Dec 01, 2023 - 11:21 EST
Investigating
We are experiencing intermittent issues on our platform. We are actively working to resolve it and will update provide an update as soon as they are resolved.
Posted Dec 01, 2023 - 10:57 EST
This incident affected: Justworks (Justworks Platform).