We are experiencing intermittent issues on our platform
Incident Report for Justworks
Resolved
This incident has been resolved.
Posted Dec 13, 2023 - 20:42 EST
Investigating
We are currently investigating this issue.
Posted Dec 13, 2023 - 20:17 EST
This incident affected: Justworks (Justworks Platform).