We are experiencing an issue with our phone support services

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 09:24 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 29, 2026 - 21:37 EDT

Investigating

We are currently investigating an issue with our phone provider, and customers are unable to reach us by phone. We encourage customers to contact us via our alternative number: (646)791-2783, or via email (support@justworks.com) or via chat on our site for any immediate assistance.
Posted Jun 29, 2026 - 19:42 EDT
This incident affected: 24/7 Support.