Justworks Time Tracking is Offline
Incident Report for Justworks
Resolved
This incident has been resolved.
Posted Oct 23, 2024 - 18:39 EDT
Investigating
We are currently working on identifying the issue.
Posted Oct 23, 2024 - 18:14 EDT
This incident affected: Justworks Time Tracking (Justworks Hours Platform, Justworks Hours Mobile App).