We are investigating an issue with customers being able to access Justworks

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted May 15, 2025 - 11:57 EDT

Investigating

We are currently investigating an issue where customers are unable to access parts of their Justworks accounts.
Posted May 15, 2025 - 11:44 EDT
This incident affected: Justworks (Justworks Platform).