Justworks Hours customers are unable to log shifts via web and mobile applications
Incident Report for Justworks
Resolved
This incident has been resolved and we'll continue to monitor for any lingering issues.
Posted Mar 01, 2023 - 09:55 EST
Update
We are continuing to investigate this issue.
Posted Mar 01, 2023 - 09:54 EST
Update
We are continuing to investigate this issue.
Posted Mar 01, 2023 - 09:46 EST
Investigating
We are currently investigating the issue.
Posted Mar 01, 2023 - 09:38 EST
This incident affected: Justworks Time Tracking (Justworks Hours Website, Justworks Hours Platform, Justworks Hours Mobile App).