Customers are currently unable to access their Justworks accounts

Incident Report for Justworks

Resolved

Customer are now able to access their Justworks accounts.
Posted May 08, 2025 - 21:35 EDT

Identified

Customers should now be able to access their accounts on Justworks. We are continuing to investigate partial outages.
Posted May 08, 2025 - 19:41 EDT

Investigating

We are investigating an issue with customers not being able to access their Justworks and Justworks Payroll accounts.
Posted May 08, 2025 - 19:13 EDT
This incident affected: Justworks (Justworks Platform).