Phone outage — please use email, live chat, and Slack to reach support
Incident Report for Justworks
Resolved
This incident has been resolved.
Posted Apr 27, 2023 - 12:59 EDT
Investigating
We are currently experiencing an outage with our phone service provider, which is preventing our team from being connected to incoming and outbound calls. You can still reach us via email, live chat, and Slack.
Posted Apr 27, 2023 - 12:14 EDT
This incident affected: 24/7 Support.