Email outage — please use phone, live chat, and Slack to reach support
Incident Report for Justworks
Resolved
This incident has been resolved.
Posted Aug 12, 2023 - 09:00 EDT
Monitoring
We have recovered all emails sent to support@justworks.com between Thursday, August 9th 4:45PM EST to Friday, August 10th 7:30PM EST. Our team is in the process of responding to all inbound inquires.

If an issue is urgent, we recommend reaching us via our Help Center chat app, Justworks chat app, or phone.

Help Center: https://help.justworks.com/hc/en-us
Phone: (888) 534-1711
Posted Aug 11, 2023 - 17:48 EDT
Identified
The outage to support@justworks.com is now resolved.

We are still in the process of recovering emails sent to support@justworks.com between Thursday, August 9th 4:45PM EST to Friday, August 10th 7:30PM EST.

If an issue is urgent, we recommend reaching us via our Help Center chat app, Justworks chat app, or phone.

Help Center: https://help.justworks.com/hc/en-us
Phone: (888) 534-1711
Posted Aug 10, 2023 - 20:14 EDT
Investigating
We are currently experiencing an outage with our email service provider, which is preventing our team from receiving inbound emails to support@justworks.com. We apologize for the inconvenience.

You can still reach us via our Help Center chat app, Justworks chat app, or phone.

Help Center: https://help.justworks.com/hc/en-us
Phone: (888) 534-1711
Posted Aug 10, 2023 - 17:14 EDT
This incident affected: 24/7 Support.