We are experiencing an issue with our phone system

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 11:40 EDT

Update

We are continuing to investigate this issue.
Posted Jul 30, 2026 - 11:39 EDT

Update

We are continuing to investigate this issue.
Posted Jul 30, 2026 - 11:38 EDT

Investigating

We are currently investigating an issue with our phone system and customers are unable to reach us by phone. We encourage customers to contact us via email (support@justworks.com) or via the Chatbot on our site for any immediate assistance.
Posted Jul 30, 2026 - 11:07 EDT
This incident affected: 24/7 Support.