We are currently experiencing issues with several features in the Justworks product
Incident Report for Justworks
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 14:14 EDT
Monitoring
We have identified the issue with our reports and have implemented a fix to make them available. We are now monitoring the change.
Posted Mar 15, 2024 - 13:50 EDT
Update
We've restored service with Justworks Time Tracking and we're now investigating our reporting features which are still unavailable for customers.
Posted Mar 15, 2024 - 11:38 EDT
Investigating
We are currently investigating an issue that is impacting our reports, invoices, timecard syncs, and calendar functionality.
Posted Mar 15, 2024 - 10:02 EDT
This incident affected: Justworks (Justworks Platform) and Justworks Time Tracking (Justworks Hours Platform).