Degraded performance across app

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 11:06 EDT

Update

We are continuing to investigate this issue.
Posted Aug 06, 2026 - 11:03 EDT

Investigating

We are experiencing issues with various parts of the product.
Posted Aug 06, 2026 - 10:39 EDT
This incident affected: Justworks (Justworks.com Website, Justworks Platform, Justworks Mobile App), Justworks Time Tracking (Justworks Time Tracking Website, Justworks Time Tracking Platform, Justworks Time Tracking Mobile App), Justworks Payroll (Justworks Payroll Platform), and 24/7 Support, Multi-factor Authentication.