Data from Justworks Time Tracking is not successfully sending to Justworks PEO
Incident Report for Justworks
Resolved
This incident has been resolved.
Posted Dec 04, 2023 - 15:56 EST
Update
We are currently aware of shifts not being sent over from Time Tracking to the PEO, notes not appearing in Time Tracking, and the payroll report not working
Posted Dec 04, 2023 - 14:09 EST
Investigating
We are currently investigating this issue.
Posted Dec 04, 2023 - 14:01 EST
This incident affected: Justworks Time Tracking (Justworks Hours Platform, Justworks Hours Mobile App).