Phones and chat service may be delayed due to weather systems near our offices
Incident Report for Justworks
Resolved
This incident has been resolved.
Posted Jan 10, 2024 - 08:56 EST
Monitoring
Due to several state of emergency statuses near our offices, there may be an impact or delay to our replies on chat and/or ability to answer phone calls.

We are currently monitoring all channels.
Posted Jan 09, 2024 - 14:24 EST
This incident affected: 24/7 Support.