Justworks Hours Customers are Unable to Log In to Their Accounts
Incident Report for Justworks
Resolved
This incident has been resolved and customers can now log in to their accounts.
Posted Apr 11, 2023 - 18:47 EDT
Investigating
We are investigating this issue and will provide updates as we have them.
Posted Apr 11, 2023 - 18:36 EDT
This incident affected: Justworks Time Tracking (Justworks Hours Platform, Justworks Hours Mobile App).