We are experiencing intermittent issues with various portions of our application

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 17:21 EDT

Monitoring

Features are recovering and we are monitoring fixes that have been put in place.
Posted Oct 14, 2025 - 14:10 EDT

Update

We are continuing to investigate this issue.
Posted Oct 14, 2025 - 10:09 EDT

Investigating

We are investigating the issue
Posted Oct 14, 2025 - 09:15 EDT
This incident affected: Justworks (Justworks Platform, Justworks Mobile App).