Justworks Hours is currently offline
Incident Report for Justworks
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 18:15 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 06, 2023 - 16:30 EDT
Investigating
We are investigating the issue for our mobile and web app being offline.
Posted Apr 06, 2023 - 16:12 EDT
This incident affected: Justworks Time Tracking (Justworks Hours Website, Justworks Hours Platform, Justworks Hours Mobile App).