We are experiencing issues with various parts of our platform.

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 18:34 EST

Monitoring

We are seeing recovery across various features and restored ability to log in. We are still monitoring.
Posted Jan 12, 2026 - 18:10 EST

Investigating

Customers may hit an error when attempting to log in to their accounts as well as when trying to access features such as documents and invoices. We are investigating the issue.
Posted Jan 12, 2026 - 17:47 EST
This incident affected: Justworks Payroll (Justworks Payroll Platform) and Justworks (Justworks Platform).