We are experiencing an issue with our phone support services

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 22:34 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 06, 2026 - 21:19 EST

Investigating

We are currently experiencing an issue with our phone support services and may be unable to answer your calls. Please email us at support@justworks.com or chat with us for immediate assistance.
Posted Jan 06, 2026 - 18:45 EST
This incident affected: 24/7 Support.