We are experiencing an issue with our phone support services

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 13:49 EDT

Monitoring

A fix has been implemented and we are monitoring results
Posted Jun 05, 2026 - 13:33 EDT

Investigating

We are currently experiencing an issue with our phone support. Please email or chat with us for immediate help.
Posted Jun 05, 2026 - 10:02 EDT
This incident affected: 24/7 Support.