Justworks PEO is currently down and offline

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 19:01 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 03, 2025 - 14:12 EST

Identified

Justworks PEO is currently down and offline
Posted Feb 03, 2025 - 13:53 EST
This incident affected: Justworks (Justworks Platform, Justworks Mobile App).