Impact to service due to Hurricane Milton

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Oct 14, 2024 - 11:03 EDT

Monitoring

Due to the impact of Hurricane Milton in Florida and surrounding areas, our responses to support inquiries may be delayed. We encourage customers to reach us via email to avoid phone wait times. Thank you for your patience.
Posted Oct 09, 2024 - 09:01 EDT
This incident affected: 24/7 Support.