We are investigating an issue with customers being able to access portions of Justworks

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 17:15 EST

Monitoring

We are seeing service return as expected and are monitoring results.
Posted Feb 18, 2026 - 13:38 EST

Investigating

We are currently investigating an issue with customers being able to access parts of the Justworks product
Posted Feb 18, 2026 - 12:34 EST
This incident affected: Justworks Payroll (Justworks Payroll Platform) and Justworks (Justworks Platform).