Customers are currently unable to access their Justworks accounts

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted May 05, 2026 - 12:25 EDT

Monitoring

We are seeing recovery with customers being able to access their accounts and we are continuing to monitor.
Posted May 05, 2026 - 11:24 EDT

Identified

We are investigating issues with customers being able to access their Justworks accounts
Posted May 05, 2026 - 10:56 EDT
This incident affected: Justworks Payroll (Justworks Payroll Platform) and Justworks (Justworks Platform).