We are experiencing issues with our Compliance Training features

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 16:57 EDT

Investigating

Customers may receive an error message that their subscription has ended while trying to access or complete assigned trainings in their Justworks account.
Posted Jul 09, 2026 - 12:37 EDT
This incident affected: Justworks Payroll (Justworks Payroll Platform) and Justworks (Justworks Platform).