Customers may not be able to access Justworks Hours or enter time for their shifts

Incident Report for Justworks

Resolved

This incident has been resolved and customers can now access their Justworks Hours accounts.
Posted Jun 07, 2023 - 09:55 EDT

Identified

We are actively working on the issue.
Posted Jun 07, 2023 - 09:41 EDT
This incident affected: Justworks Time Tracking (Justworks Time Tracking Website, Justworks Time Tracking Platform, Justworks Time Tracking Mobile App).