We are experiencing degraded services for parts of our product

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 17:06 EST

Monitoring

We've implemented a fix and we're monitoring results
Posted Nov 25, 2025 - 16:50 EST

Identified

We believe we've identified the issue and we're implementing a fix.
Posted Nov 25, 2025 - 16:48 EST

Investigating

We are currently investigating the issue and will provide updates.
Posted Nov 25, 2025 - 16:31 EST
This incident affected: Justworks (Justworks Platform).