We are experiencing an issue with our phone support services

Incident Report for Justworks

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:14 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 11:10 EDT

Identified

We are currently investigating an issue with our phone provider and customers are unable to reach us by phone. We encourage customers to contact us via email (support@justworks.com) or via the Chatbot on our site for any immediate assistance.
Posted Oct 20, 2025 - 10:30 EDT
This incident affected: 24/7 Support.